WeInfuse Loading Issues
Incident Report for WeInfuse
Resolved
This incident has been resolved. The application is now loading for users.
Posted Jan 14, 2025 - 16:31 CST
Update
We are continuing to investigate this issue.
Posted Jan 14, 2025 - 16:23 CST
Investigating
Our team is currently investigating an issue preventing the application from loading for users. We will post updates every 15 minutes.
Posted Jan 14, 2025 - 15:55 CST
This incident affected: WeInfuse Application.